WEpayments - Incident Detected – Incident details

All systems operational

Incident Detected

Resolved
Major outage
Started about 1 month agoLasted 17 minutes
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We've detected an incident that could impact your operations, potentially causing downtime for the payment creation service.

    Our technical team is actively investigating the root cause and impact. We will provide updates as more information becomes available.